Login issue

Anything to do with this site.
Post Reply
User avatar
PodHopper
Posts: 7
Joined: Wed Nov 25, 2020 11:27 am
Contact:

Login issue

Post by PodHopper »

When I tried to login using the login icon on the top right of the site it gives an internal error 500. This happened on the main webpage (urutunes.com) as well as on the calendar page. However, when I go to the forum and login using the login at the bottom there it works...
User avatar
Ezriilc
Site Admin
Posts: 46
Joined: Sun May 24, 2020 10:43 am

Re: Login issue

Post by Ezriilc »

Everything seems fine to me. I wonder if there was a temporary error.
User avatar
PodHopper
Posts: 7
Joined: Wed Nov 25, 2020 11:27 am
Contact:

Re: Login issue

Post by PodHopper »

Shorah,

Just tested it again. On the forum page it works as expected, both the login link at the top and the one at the bottom. However on the main page and the calendar page I get the following error (see screenshot).
Image

Hope you can make something of it :)
User avatar
Ezriilc
Site Admin
Posts: 46
Joined: Sun May 24, 2020 10:43 am

Re: Login issue

Post by Ezriilc »

Yep, I'm getting it now too, when clicking login from the front page or calendar is triggering it.

I'll get on it right away, and report back here.
User avatar
Ezriilc
Site Admin
Posts: 46
Joined: Sun May 24, 2020 10:43 am

Re: Login issue

Post by Ezriilc »

Right, so I've made a "fix" that is really just a work-around. The login link works, but doesn't redirect the user back to the original page after logging in. In other words, after logging in, it dumps you into the forum index, rather than the home page or calendar.

EDIT: It appears that once a user is logged in and goes back to the home/calendar page, it still shows the user as not logged in, but the user is actually logged in. This is because what I did was an ugly hack. :mrgreen:

This seems to be a glitch in either my Apache server config or the PHPBB software itself. I will continue to pursue this problem to find the actual issue and fix it properly.
User avatar
PodHopper
Posts: 7
Joined: Wed Nov 25, 2020 11:27 am
Contact:

Re: Login issue

Post by PodHopper »

I realize it's only a temporary solution what we have now, but the calendar page thinks that I'm not logged in (even when I did login) so it will not let me change the calendar entries I made. Anyway, no rush, I only wanted to correct an entry for May 11. But it can wait...

Edit: Strictly speaking, the way it was allowed you at least to edit the calendar, once you found your way to the forum to login...
User avatar
Ezriilc
Site Admin
Posts: 46
Joined: Sun May 24, 2020 10:43 am

Re: Login issue

Post by Ezriilc »

PodHopper wrote: Sat Apr 17, 2021 11:31 am I realize it's only a temporary solution what we have now, but the calendar page thinks that I'm not logged in (even when I did login) so it will not let me change the calendar entries I made. Anyway, no rush, I only wanted to correct an entry for May 11. But it can wait...
OH! :o Well, that is a problem, dang-it. I was aware it still showed the login button, but I thought it would still see you as online for the purpose of editing the calendar.

I may just get rid of the login button on the home/calendar pages altogether - they live outside of the forum proper, so there's special magics going on to integrate. It all seemed to work perfectly when I built it, but there have been updates to PHPBB, so all bets are off.

I appreciate your patience and reports. I'm not much of an expert, but I should be able to fix it properly... eventually. :oops:
User avatar
PodHopper
Posts: 7
Joined: Wed Nov 25, 2020 11:27 am
Contact:

Re: Login issue

Post by PodHopper »

Thanks Ezri,

As I said: no rush. It will come to you. It always does to me... :geek:
User avatar
Ezriilc
Site Admin
Posts: 46
Joined: Sun May 24, 2020 10:43 am

Re: Login issue

Post by Ezriilc »

PodHopper wrote: Sat Apr 17, 2021 12:12 pm As I said: no rush. It will come to you. It always does to me... :geek:
Your positive energy helped me get it together, so thanks! In trouble-shooting, I had messed with a thing I shouldn't have. :oops:

It now has my "ugly hack" done as I meant, and it works, including the Calendar. :shock:
User avatar
Ezriilc
Site Admin
Posts: 46
Joined: Sun May 24, 2020 10:43 am

Re: Login issue

Post by Ezriilc »

This morning I could not login to UruTunes from my phone because it kept throwing a "The form is invalid..." error.

I am working on this, and hope to have it fixed in the next few minutes. I'll report back here again when I think it's done.
User avatar
Ezriilc
Site Admin
Posts: 46
Joined: Sun May 24, 2020 10:43 am

Re: Login issue

Post by Ezriilc »

Ezriilc wrote: Sun Apr 18, 2021 9:32 am This morning I could not login to UruTunes from my phone because it kept throwing a "The form is invalid..." error.

I am working on this, and hope to have it fixed in the next few minutes. I'll report back here again when I think it's done.
I think I have it fixed "once and for all" now! :mrgreen: We shall see...
User avatar
PodHopper
Posts: 7
Joined: Wed Nov 25, 2020 11:27 am
Contact:

Re: Login issue

Post by PodHopper »

Ok, I hereby confirm that it is working for me. Tested it by logging in via the main page as well as via the calendar page and in both cases it works. Thanks :D
User avatar
Ezriilc
Site Admin
Posts: 46
Joined: Sun May 24, 2020 10:43 am

Re: Login issue

Post by Ezriilc »

PodHopper wrote: Tue Apr 20, 2021 8:43 am Ok, I hereby confirm that it is working for me. Tested it by logging in via the main page as well as via the calendar page and in both cases it works. Thanks :D
You're very welcome. I'm happy to serve the community. :D
User avatar
Ezriilc
Site Admin
Posts: 46
Joined: Sun May 24, 2020 10:43 am

Re: Login issue

Post by Ezriilc »

Interestingly, my hosting provider is currently looking into this issue, as it seems to stem from the Apache server we're using. It's not happy with the phpBB login link, but it's not obvious why (to me, anyway).

So, PodHopper may well have helped other folks too, by noticing and reporting it. Well done!

I'll keep y'all posted!
User avatar
Ezriilc
Site Admin
Posts: 46
Joined: Sun May 24, 2020 10:43 am

Re: Login issue

Post by Ezriilc »

So, the saga so far...

My hosting provider fixed the error thrown by the front page login link, which I then ended up removing. :?

When I first installed this forum, I had it integrated into the Home page for the purpose of enabling registered users to edit the Calendar. That was the only real need for the integration.

PodHopper suggested that we really didn't need another calendar related to Uru Live events, especially since the Guild of Messengers' calendar is so great. So, I killed our calendar - which wasn't great at all - changed the link to point to GoMe, and disconnected the Home pages from the forum. I'm sorry if this inconveniences anyone.

I've since rewritten the Home page to make it pretty, and I think I'm happy with it.

As always, if anyone has any issues, please let me know. :ugeek:

EDIT: Oh! I forgot to thank PodHopper here for their reports and all the helpful input. Thanks again! :D
Post Reply